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PRO-MAIL® 5.0+ Interface to Post 
Master™ 
Easy Steps To Success 

1. Obtain a Pro-Mail registration code for Post Master™. 
2. Apply Post Master™ program setup information. 
3. Create postage statements. 
4. Export postage statement data to Pro-Mail. 

 
 

SETUP 
  
1. Do a normal POST MASTER™ single user or network installation.  You will 
need to create a logical drive mapping for the drive on your network that can be 
accessed by both your POST MASTER™ and Pro-Mail 5 program. 
  
2. On each workstation that will be using POST MASTER™, you must setup an 
ODBC System DSN data source pointing to the database that will be used by 
Pro-Mail 5.  The procedure for doing this will vary with each version of Windows 
but you will need to know which server the database is on, the name of the 
database and the login and password to access the database before you start 
your configuration.  The folder that we need to point to is the one that holds Pro-
Mail’s Warehouse database.  
 
3. Select the “Program Setup” option on Post Master™’s File Menu..  In 
order to enable the Pro-Mail 5 mode, you must obtain a registration key from 
Window Book that supports this feature.  Versions of POST MASTER™ earlier 
than 5.02.01.01 did not require a special key.   
  
At the Defaults Tab, select Pro-Mail from the drop-down box in the lower left 
hand corner of the screen. 
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4. Press the Settings button.  Select the data source you set up for Pro-Mail 5 
and enter the user name and password that is required to access this database. 
 
5. Next, click on the Export Tab: 
 

 
 
6. Highlight the Pro-Mail 5, XML option and press the Change option.  
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7. Do check Enable Pro-Mail 5, XML Export (note, you can have both Pro-Mail 4 
and 5 interfaces enabled and data will be sent to both systems which may be 
useful during a transition period).   
  
8. Select the folder on the network using the lookup button on the right of the 
Export Folder field where you will be sending your Pro-Mail data. This is usually 
something like H:\Gomi depending on how you mapped the network drive that 
can be accessed by Pro-Mail. 
  
9. Do Not check off the XML Test checkbox.  This will include container level 
detail in your XML files which is not used by Pro-Mail at this time. 
  
10. Press the OK button on the Job Shop Export Settings dialog. 
 
11. Do check off ‘Export Only Verified Statements’ on the Export tab of Program 
Setup.  Press the OK button at the bottom of the screen to save your set-ups. 
  
12. Repeat steps 3 and 4 to select your ODBC datasource and enter login info 
for ALL workstations using Post Master™.  You will not have to repeat the 
other setup changes. 
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AT THE PRO-MAIL 5 END 
 

 
 
In the Production Control System, go to Setup, System Parameters then set XML 
directory to Gomi  (or a subfolder of Gomi if you wish).   
  

 
PROJECT MANAGEMENT  
  
1. Make sure the Postage Liability and Postage Inventory Accounts have been 
assigned account numbers in the Setup Screen 
 
2. Import Entry Point information.  You can export a list of USPS entry points 
from the file menu of your Post Master™ Statement Printing Program then import 
it in Pro-Mail’s Project Management System.  To import the Window Book file of 
destinations, log into the  Production Control . Go into Utilities > Import Drop 
Destinations. The file should reside in Gomi. Enter the file name to import or 
browse the directory to select the file. 
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USING POST MASTER™ WITH PRO-MAIL 5 
 
When creating statements with Post Master™, you may either use the drop data 
you have setup in Pro-Mail 5 in advance or create the drops on the fly be 
entering a drop number into Post Master™’s ‘Lot’ field that has not already been 
used to define a drop for the job you are creating statements for.  Post 
Master™’s “LOT” field is used for the Pro-Mail Drop Number and the “Package” 
field is used for the package number.  Lookups are provided for each.  The Drop 
lookup will display automatically after you select a job so you can select a valid 
drop for that job.  When you get to the package field, press that lookup button 
and select a valid drop for that job. The single piece weight will be populated on 
the statement automatically though you can override it. Both Lot and Package 
fields are required. 
 Important Note:  You do NOT have to select a Pro-Mail 5 Drop when creating 
statements manually.  If the drop number you wish to assign is not already in 
Pro-Mail, you may enter your own, though you should take care to make it unique 
for the job.  When the statement is imported into Pro-Mail 5, the drop will be 
added automatically. 
Unlike the Drop Number, you MUST use a valid Pro-Mail 5 Package ID when 
creating statements otherwise the statement data will fail to be imported. 
 
Unlike Pro-Mail 4, Pro-Mail 5 and POST MASTER™ support multiple packages 
per drop so you can create statements with either 1 package per drop or multiple 
packages per drop  Here is how:. 
 
Creating Single Package per Drop Statements 

a. When creating a “Normal” (single package) statement, enter the job 
number and press TAB.  You can also lookup the job directly from Pro-
Mail’s table by pressing the lookup button to the right of the Job field. 
  
 b. Select the Drop.  After you select or entry the job, you will see a list of 
drops appear.  Select one.  The program will update the ‘Lot’ field with the 
drop number and select the appropriate entry point for you automatically. 
  
 c. Press the lookup button next to the Package Field and select a Pro-Mail 
package.   The weight of the package will be updated to Post Master™’s 
Weight field.  The weight will be in ounces or lbs depending on what was 
originally setup in Pro-Mail 5. 
  
 d. Select the Permit by pressing the lookup button.  This permit info is 
coming right from Pro-Mail’s tables 
  
.e. Create and print the rest of the statement as usual. 

 
Creating Multi-Package per Drop Statements (First Class and Standard Mail 
Only) 
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a. When creating a new statement, indicate “multi-package” as the 
statement type in the first entry field 
  
b. Select a job then a drop as described for single package statements. 
  
c. Enter the rest of the statement info per usual and enter something in the 
weight field, even if it is not correct. 
  
d. Go to the calculation tab and double click on any rate.  You will see 
 button and you will see the “Multi Job/Client listing.  Press the Insert key go 
to the Package field.  Press the lookup button and select a package. 
  
e. Click on the Calculation tab and enter your piece counts for this package. 
 When done press the OK button at the top of the screen then press the 
Insert button again to add a new package then select which package that is 
and enter our counts. 
  
f. Repeat until all packages for this drop have been entered.  Remember, 
this feature only allows you to create drops with multiple packages.  If you 
want to create statements with multiple drops, you should be creating 
Consolidated statements. 
  

Transferring Postage Data to Pro-Mail 5 
a. Go to the Statement Menu and use the icon with the blue checkmark on 
the toolbar to check off all statements that have been round stamped and 
whose postage matches the amount in the database.  You can view the 
total postage without editing the statement by pressing ‘details’ or scrolling 
to the right.  Checking off the statement indicates the postage is final and 
you will not easily be able to delete or change this statement. 
  
 b. Go to the File Menu and select the option to Export Jobshop 
Statements.  Within a minute or so all your postage data will automatically 
show up in Pro-Mail. 
  

Transferring BMC, SCF and ADC data to Pro-Mail 5.   
a. Go to Postmaster’s File Menu 
  
b. Select ‘Export Entry Points’.  The labeling list data in Post Master™ will 
be transferred to Pro-Mail 5.0.  Note- at this time ADC’s used by Periodical 
Mailers are listed with BMC’s.  When setting up a BMC drop for Standard 
Mail or Parcel Services, be sure to select the BMC not ADC entry. 
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Using the PRO-MAIL® 5.0+ Interface  
Easy Steps To Success 

1. Obtain a PRO-MAIL registration code for DAT-MAIL™. 
2. Apply DAT-MAIL™ program setup information. 
3. Create Window Book XML file directory in PRO-MAIL. 
4. Define drop information then export to PRO-MAIL for Work Tickets. 
5. Create postage statements. 
6. Export postage statement data to PRO-MAIL. 

 
 

SETUP 
  
1. Do a normal DAT-MAIL™ single user or network installation.  You will need to 
create a logical drive mapping for the drive on your network that can be accessed 
by both your DAT-MAIL™ and PRO-MAIL 5 program. 
  
2. On each workstation that will be using DAT-MAIL™, you must setup an ODBC 
System DSN data source pointing to the database that will be used by PRO-
MAIL 5.  The procedure for doing this will vary with each version of Windows. 
 You will need to know which server the database is on, the name of the 
database, and the login and password to access the database before you start 
your configuration.  The folder that we need to point to is the one that holds PRO-
MAIL’s Warehouse database. 
  
3. Press the ‘3602’ Button on the DAT-MAIL™ Toolbar to open DAT-
MAIL™’s Statement Program then Go to the File Menu and select Program 
Setup .  In order to enable the PRO-MAIL 5 mode, you must obtain a registration 
key from Window Book that supports this feature. Versions of DAT-MAIL™ 
earlier than 5.02.01.01 did not require a special key.  
  
On the DAT-MAIL™ Statements side of the program, select FILE => Program 
Setup.   
  
At the Defaults Tab, select PRO-MAIL from the drop-down box in the lower left 
hand corner of the screen. 
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4.  Press the Settings button.  Select the data source you set up for PRO-MAIL 5 
and enter the user name and password that is required to access this database. 
  
5. Next, click on the Export Tab: 
  

 
 
6.  Highlight the PRO-MAIL 5, XML option and press the Change option.  
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7.  Do check Enable PRO-MAIL 5, XML Export (note, you can have both PRO-
MAIL 4 and 5 interfaces enabled and data will be sent to both systems which 
may be useful during a transition period).  .   
  
8.  Select the folder on the network using the lookup button on the right of the 
Export Folder field where you will be sending your statements data to PRO-MAIL. 
This is usually something like H:\Gomi depending on how you mapped the 
network drive that can be accessed by PRO-MAIL. 
  
9.  Do Not check off the XML Test checkbox. as this will include container level 
detail in you XML files, which is not used by PRO-MAIL at this time. 
  
10.  Press the OK button on the Job Shop Export Settings dialog. 
  
11.  Do check ‘Export Only Verified Statements’ on the Export tab.  Press the OK 
button at the bottom of the screen to save your set-ups.  If you cannot see the 
OK button, try repositioning your window or use your Ctrl+O keys. 
  
12.  Repeat steps 3 and 4 to select your ODBC data source and enter login info 
for ALL workstations using DAT-MAIL™.  You will not have to repeat the other 
setup changes. 
  
Go back to the main DAT-MAIL™ Program.  Click on FILE => Program Setup => 
Export/Archive tab. 
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Set the Export Path Name to the folder that PRO-MAIL will use to receive the 
work ticket data (i.e. S:\GOMI). 
  
Do check the PRO-MAIL 5 checkbox as the Export Format. 
  
Do Not check the box to allow export of container detail. 
 
Now click on the OK button to save your settings. 
 

 
IN THE PRO-MAIL 5 SOFTWARE: 
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In the Production Control System, go to Setup, System Parameters then set XML 
directory to Gomi  (or a subfolder of Gomi if you wish).   
 

 
PROJECT MANAGEMENT  
  
1.  Make sure the Postage Liability and Postage Inventory Accounts have been 
assigned account numbers in the Setup Screen. 
 
2.  Import Entry Point information.  You can export a list of USPS entry points 
from the file menu of your DAT_MAIL Statement Printing Program then import it 
in PRO-MAIL’s Project Management System.  To import the Window Book file of 
destinations, log into the Production Control . Go into Utilities > Import Drop 
Destinations. The file should reside in Gomi. Enter the file name to import or 
browse the directory to select the file 
 

 
USING DAT-MAIL™ WITH PRO-MAIL 5 
  
Creating Work Tickets from Mail.dat Information 
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After you import Mail.dat files for a job, you can make whatever changes you 
wish such as using our ‘Quick Plan’ or Planalyzer to optimize your entry plan. 
 You can also assign Package Numbers to match those already created or, force 
PRO-MAIL to create new packages for each version.   
  
MAKE SURE THE JOB NUMBER IS CORRECT 
 
Look at the job number at the top of the screen.  If that is not right, you can 
correct it by clicking on the View menu and selecting File Info view.  Change the 
Job Number so that it matches the one you have in PRO-MAIL 
 

 
ASSIGNING PACKAGE NUMBERS 
  
Package Numbers:  You normally would have defined your packages before 
even doing the presort. What you want to do is assign the PRO-MAIL package 
number to your Mail.dat information before you do your first export to PRO-MAIL. 
 This way your existing package information is used.  If you do not do this, PRO-
MAIL will create new packages for each MPU Name, and you will have to define 
each packages' contents in PRO-MAIL.  In Mail.dat, the PRO-MAIL package 
number is represented by the MPU Name.  To see this information as it exists in 
your Mail.dat file, click on the View menu and select Mail Piece Unit File view 
after you have imported or opened a Mail.dat file in DAT-MAIL™.  You can easily 
assign a PRO-MAIL 5 package ID to the MPU Name field by highlighting an MPU 
record and pressing the “Package ID to Description” button.  This will give you a 
list of PRO-MAIL 5 Package ID’s and you can select the one you want.  You can 
then copy that package to other MPU records by using the “Copy Desc.” Button 
or change the other MPU records individually 
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In the example above, the Package Name for all MPU names  is “1”(MPU is a 
version but there is a different MPU record created for each ‘segment’ in the 
mailing).  This means that when PRO-MAIL imports this data, it will assign 
package 1 to this mailing.  If Package 1 is already defined, you will be ready to 
create work tickets.   
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If there were multiple MPU records in the Mail.dat file, you would need to copy 
the MPU name to each record.  If a mailing has multiple segments, the same 
MPU Name is needed many times, even though the mailing was for identical 
versions.  
  

 
 
Highlight the record you just changed and press the ‘Copy Desc.’ button.  You 
can copy the new MPU name to all MPU records or to just the records with the 
same original MPU name.    
 

 
CREATING AND SCHEDULING DROPS FOR WORK TICKETS 
  
When such changes are complete, click on the View menu and select Mail 
Schedule View.  In this view you can easily schedule the drop dates for each 
entry point.  If you are participating in CONFIRM, you can also schedule the 
dates and times each shipment is supposed to reach the appropriate mailing 
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facility. 
  
The MAIL SCHEDULE VIEW lets you sort your data each way.  Drop Numbers 
will be assigned in the displayed order to all entry points. This tab may be more 
convenient even for large single segment mailings since it features a ‘tag table’ 
that allows you to mark a number of records which are being shipped on the 
same date.  Tag all the records you are shipping on a single day, chance one of 
the tagged records and change the mail date to the correct date.  Note:  In-Home 
date must be later than Mail Date even if you do not use In-Home date. 
 

 
 
You can tag the entry points you want to change by using the Tag check marks, 
Tag by Range button, or the wite boxes to the left of each line item. This view 
allows for Windows tagging conventions so that you can left-click on the first 
entry point, and then hold the shift key down and tag the last.  All items in 
between will be tagged.  
 
When all items that are going to be mailed on a particular date are tagged, you 
would highlight one of these entries and press the CHANGE button.  This would 
present the following screen: 
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You would then enter the estimated mailing date or press the calendar lookup 
button to select this date from a calendar.  You must also select an in-home date. 
 If you are participating in CONFIRM, you would also press the Estimated Drop 
Date,  which is the date the mail is expected to reach the postal facility (not the 
date ‘dropped’ by the mailer which is really the estimated mailing date).  You can 
also enter the estimated time that the shipment is supposed to arrive at the 
postal facility and the drop ship appointment number, if either known in the 
Estimated Drop Time and DS Appointment No. fields.  Press OK to save.  The 
information will be updated and displayed on the list. 
 
When all the drop dates are correct, press the Export to PRO-MAIL 5 button. 
 You will get this message: 
 

 
 
Next you will be able to see where the file will be created and what its' name will 
be (though you won’t really need to know this since PRO-MAIL will import your 
data automatically).  You can set the starting drop ID to whatever you want. 
 Drop ID’s will be unique across all jobs unless you reset to 1 on this screen. 
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When you click OK, the data for this mailing will be passed to PRO-MAIL.  You 
should be able to retrieve this in PRO-MAIL to create work tickets about a minute 
after the export has stopped. 
   

 
Creating Statements  
 
Now that you have created work ticket information, your next step is to create the 
actual Postage Statements.  In DAT-MAIL™ that is done in the Generate 
Statements View.  This process will go just as it does for other DAT-MAIL™ 
users.  The difference is that on the statement generate screen, the Job, Client 
and Permit lookup will be coming from PRO-MAIL 5. Any new information 
selected will be automatically imported into DAT-MAIL™’s own ‘master files’ 
during statement generation.  Once statement data is generated, you can print 
statements and  reports from the DAT-MAIL™ Statement printing program.  See 
the User Guide section titled "Mail.dat Statement Generation" for detailed 
instructions on how this is done.  If, when printing a report for a job, you do not 
see the job you want listed, it is very unlikely that there is any statement 
information present in the system for that job.  You can press the ‘Pro Mail Sync’ 
button on the Job, Client or Permit File lookup to be sure that DAT-MAIL™’s 
master files include entries for all of the PRO-MAIL jobs, entities or permits but 
this will rarely be necessary. 
 
Manually (without a Mail.dat file) 
 
DAT-MAIL™ allows you to not only create statements from Mail.dat but also to 
create them without Mail.dat  When you create a statement from Mail.dat, we are 
assuming you are passing the drop information to the PRO-MAIL Work Ticket 
program before creating statements. This is how PRO-MAIL will know about the 
Drops in the system and have packages assigned. 
 
When creating manual statements with DAT-MAIL™, you may either use the 
drop data you have setup in PRO-MAIL 5 in advance or create the drops on the 
fly be entering a drop number into Post Master™’s ‘Lot’ field that has not already 
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been used to define a drop for the job you are creating statements for.   DAT-
MAIL™’s “LOT” field is used for the PRO-MAIL Drop Number and the “Package” 
field is used for the package number.  Lookups are provided for each of the 
fields.  The Drop lookup will display automatically after you select a job so you 
can select a valid drop for that job.  When you get to the Package field, press that 
lookup button and select a valid drop for that job. The single piece weight will be 
populated on the statement automatically, although you can override it.  Both the 
Lot and Package fields are required.   
 
Important Note:  You do NOT have to select a PRO-MAIL 5 Drop when creating 
statements manually.  If the drop number you wish to assign is not already in 
PRO-MAIL, you may enter your own, though you should take care to make it 
unique for the job.  When the statement is imported into PRO-MAIL 5, the drop 
will be added automatically. 
   
Unlike the Drop Number, you MUST use a valid PRO-MAIL 5 Package ID when 
creating statements otherwise the statement data will fail to be imported.   
 
Please reference the User Guide section titled "Manual Statements to access 
detailed information on the steps to create these statements.   
 
Unlike PRO-MAIL 4, PRO-MAIL 5 and DAT-MAIL™ support multiple packages 
per drop, so you can create statements with either 1 package per drop or multiple 
packages per drop  Here is how:. 
   
Creating Single Package per Drop Statements Manually 
 

a. When creating a “Normal” (single package) statement, enter the job 
number and press TAB.  You can also lookup the job directly from PRO-
MAIL’s table by pressing the lookup button to the right of the Job field. 
  
b. Select the Drop.  After you select or entry the job, you will see a list of 
drops appear.  Select one.  The program will update the ‘Lot’ field with the 
drop number and select the appropriate entry point for you automatically. 
  
c. Press the lookup button next to the Package Field and select a PRO-
MAIL package.   The weight of the package will be updated to DAT-
MAIL™’s Weight field.  The weight will be in ounces or lbs depending on 
what was originally setup in PRO-MAIL 5. 
  
d. Select the Permit by pressing the lookup button.  This permit info is 
coming right from PRO-MAIL’s tables. 
 
e. Proceed by entering the rest of the statement information on the 
applicable tabs and then print. 
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Creating Multi-Package per Drop Statements (First Class and Standard Mail 
Only) 
  

a. When creating a new statement, indicate “multi-package” as the 
statement type in the first entry field (type). 
  
b. Select a job, then a drop as described for single package statements. 
  
c. Enter the rest of the statement info on the first tab, making sure to enter 
something in the piece weight field, even if it is not correct. 
 
d. Go to the Calculation Tab and double click on any rate.  You will see 
 button and you will see the “Multi Job/Client listing.  Press the Insert key go 
to the Package field.  Press the lookup button and select a package. 
 
e. Click on the Calculation tab and enter your piece counts for this package. 
 When done press the OK button at the top of the screen, then press the 
Insert button again to add a new package.  Then select which package that 
is and enter your piece counts. 
 
f. Repeat until all packages for this drop have been entered.  Remember, 
this feature only allows you to create drops with multiple packages.  If you 
want to create statements with multiple drops, you should be creating 
Consolidated statements. 
 
 

Transferring Postage Data to PRO-MAIL 5 
 
1.  Go to the Statement Menu and open the appropriate statement list.  Use the 
icon with the blue checkmark on the toolbar to Verify all statements that have 
been round stamped and whose postage matches the amount in the database. 
 You can view the total postage without editing the statement by pressing ‘details’ 
button, or by scrolling to the right. Verifying the statement indicates the postage 
is final and you will not easily be able to delete or change this statement. 
   
2.  Go to the File Menu and select the option to Export to PRO-MAIL.  Within a 
minute or so all your postage data will automatically show up in PRO-MAIL.  

 
3. Transferring BMC, SCF and ADC data to PRO-MAIL 5.   
  

a. Go to the File menu 
 
b. Select ‘Export Entry Points’.  The labeling list data in DAT-MAIL™ will be 
transferred to PRO-MAIL 5.0.  Note- at this time ADC’s used by Periodical 
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Mailers are listed with BMC’s.  When setting up a BMC drop for Standard 
Mail or Parcel Services, be sure to select the BMC, not ADC entry. 
 

 
Running Reports  
 
When running some of DAT-MAIL™’s many reports, you are often asked to do a 
report for a single client, job or permit.  Any client, job or permit which has 
statement activity should already be listed.  If for any reason, you do not see the 
job, client or permit you think should be there, press the PRO-MAIL Sync button 
on the browse.  This will refresh DAT-MAIL™’s own tables with info from PRO-
MAIL’s tables.   If the item you are looking for still does not appear after 
synchronization, the permit, client, or job may exist in PRO-MAIL, but there has 
not been any statement activity yet for DAT-MAIL™ to report on. 
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